Skip to main content
← All vulnerabilities
CVE-2026-109869GHSA-XJJ6-F33Q-929C

undici vulnerable to Denial of Service via unhandled error on excessive content-encodings

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.29.1, 7.30.1, 8.12.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • undici undici

    From 6.23.0 · fixed in 6.29.1; From 7.18.0 · fixed in 7.30.1; From 8.0.0 · fixed in 8.12.2

  • undicinpm

    From 6.23.0 · fixed in 6.29.1

  • undicinpm

    From 7.18.0 · fixed in 7.30.1

  • undicinpm

    From 8.0.0 · fixed in 8.12.2

References 2

GitHub · nodejs/undici

cna.openjsf.org