Skip to main content
← All vulnerabilities
CVE-2026-109603GHSA-PJ59-9HV9-RMRV

Frappe Framework before 16.17.0 Authenticated SSRF and LFI via pdfkit

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.107.3, 16.17.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Frappe Framework 15.x before 15.107.3 and 16.x before 16.17.0 relies on a vulnerable pdfkit library (CVE-2025-26240) for PDF generation, enabling server-side request forgery and local file inclusion. Authenticated attackers can supply crafted content to PDF rendering to make the server fetch internal resources or embed local server files in generated PDFs.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • frappe frappe

    fixed in 15.107.3; From 16.0.0-beta.1 · fixed in 16.17.0

References 2

GitHub · frappe/frappe

vulncheck.com