Skip to main content
← All vulnerabilities
CVE-2026-109275GHSA-233R-2P53-WQF5

ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 Code Injection via MVG Decoder

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.1.2-32, 6.9.13-57
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains a code injection vulnerability in the MVG decoder when a PostScript renderer is used. Attackers can supply a crafted MVG file that, when decoded, injects code into the PostScript rendering path.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • ImageMagick ImageMagick

    From 7.0.0-0 · fixed in 7.1.2-32

  • ImageMagick ImageMagick

    fixed in 6.9.13-57

References 4

GitHub · ImageMagick/ImageMagick

GitHub · ImageMagick/ImageMagick6

vulncheck.com