Skip to main content
← All vulnerabilities
CVE-2026-108598GHSA-3P4C-WP7W-MGJX

Floci 1.1.0 before 2.2.0 RCE via API Gateway VTL Mapping Templates

Published
Last modified
Status
published
Known exploitation
Not listed in CISA KEV
Fix
Fixed in 2.2.0
Public exploit
None on Exploit-DB
CISA SSVC
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: total
?

Decision points from CISA's Vulnrichment, assessed (SSVC 2.0.3).

SSVC documentation

Summary

Floci 1.1.0 before 2.2.0 contains a code injection vulnerability in VtlTemplateEngine that allows unauthenticated attackers to execute commands via unrestricted Velocity mapping templates. Attackers can create a REST API with a MOCK integration whose template uses $util reflection to reach Runtime or ProcessBuilder, executing OS commands in the Floci JVM.

Affected versions

  • floci-io floci

    From 1.1.0 · fixed in 2.2.0

References 7

GitHub · floci-io/floci

GitHub · ghostx-86/exploitarium

vulncheck.com