Backstage: Improper URL validation in catalog entity placeholder resolution
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.49.6, 1.50.5, 1.51.3, 1.53.2, 1.54.6, and 5 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- backstage backstage
fixed in 1.49.6; From 1.50.0-next.0 · fixed in 1.50.5; From 1.51.0-next.0 · fixed in 1.51.3; From 1.52.0-next.0 · fixed in 1.53.2; From 1.54.0-next.0 · fixed in 1.54.6
- @backstage plugin-catalog-backend
fixed in 3.5.1; From 3.6.0 · fixed in 3.6.2; From 3.7.0 · fixed in 3.7.2; From 3.8.0 · fixed in 3.8.2; From 3.9.0 · fixed in 3.9.1
- @backstage/plugin-catalog-backendnpm
fixed in 3.9.1