CVE-2026-105848GHSA-R9V2-GG2J-22Q5
Payload: Insufficient Access Control in Stripe REST Proxy
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.90.0, 4.0.0-canary.34
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Payload is a free and open source headless content management system. In @payloadcms/plugin-stripe versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user who can reach the enabled optional Stripe REST proxy can perform unintended Stripe operations. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- payloadcms payload
fixed in 3.90.0; From 4.0.0-canary.0 · fixed in 4.0.0-canary.34
- @payloadcms plugin-stripe
fixed in 3.90.0; From 4.0.0-canary.0 · fixed in 4.0.0-canary.34
- @payloadcms/plugin-stripenpm
fixed in 3.90.0
- @payloadcms/plugin-stripenpm
From 4.0.0-canary.0 · fixed in 4.0.0-canary.34